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 Preface

Purpose of the Manual
The purpose of this tutorial is to enable you to commission the specimen plant
described in this document.

Required Basic Knowledge
To understand the manual, you should have general experience of automation
engineering.
You should also be familiar with working on computers or PC-type machines (for
example, programming devices) with the Windows 2000 operating system. Since
SIMATIC iMap uses the STEP 7 platform, you should also be familiar with working
with the standard software described in the "Programming with STEP 7 V5.2"
manual.

Where is this Manual valid?
The manual is valid for the SIMATIC iMap V1.2 software package.

Place of this Documentation in the Information Environment
This manual is part of the SIMATIC iMap documentation package. The
documentation is installed with the software and includes the following electronic
manuals in PDF format:

• Component Based Automation and SIMATIC iMap

• Getting Started with SIMATIC iMap

• Commissioning Systems, Tutorial
The entire documentation is available for you as HTML help.

Content of this tutorial
The tutorial contains

• A description of the overall plant

• Part 1- Instructions for creating the PROFInet components and

• Part 2Instructions for commissioning the system.
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Conventions
Menu commands are printed in bold print, for example, Project > Save.

Further Support
If you have any technical questions, please get in touch with your Siemens
representative or agent responsible.

http://www.siemens.com/automation/partner
http://www.ad.siemens.de/cba/

Training Centers
Siemens offers a number of training courses to familiarize you with the SIMATIC
S7 automation system. Please contact your regional training center or our central
training center in D 90327 Nuremberg, Germany for details:
Telephone:  +49 (911) 895-3200.
Internet: http://www.sitrain.com

http://www.siemens.com/automation/partner
http://www.ad.siemens.de/cba/
http://www.sitrain.com
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A&D Technical Support
Worldwide, available 24 hours a day:

 

Beijing

Nuernberg

Johnson City

Worldwide (Nuernberg)
Technical Support

24 hours a day, 365 days a year

Phone: +49 (0) 180 5050-222

Fax: +49 (0) 180 5050-223

E-Mail: adsupport@
siemens.com

GMT: +1:00

Europe / Africa (Nuernberg)
Authorization

Local time: Mon.-Fri. 8:00 to 17:00

Phone: +49 (0) 180 5050-222

Fax: +49 (0) 180 5050-223

E-Mail: adautorisierung@
siemens.com

GMT: +1:00

United States (Johnson City)
Technical Support and
Authorization
Local time: Mon.-Fri. 8:00 to 17:00

Phone: +1 (0) 423 262 2522

Fax: +1 (0) 423 262 2289

E-Mail: simatic.hotline@

sea.siemens.com

GMT: -5:00

Asia / Australia (Beijing)
Technical Support and
Authorization
Local time: Mon.-Fri. 8:30 to 17:30

Phone: +86 10 64 75 75 75

Fax: +86 10 64 74 74 74

E-Mail: adsupport.asia@

siemens.com

GMT: +8:00
The languages of the SIMATIC Hotlines and the authorization hotline are generally German and English.
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Service & Support on the Internet
In addition to our documentation, we offer our Know-how online on the internet at:
http://www.siemens.com/automation/service&support

where you will find the following:

• The newsletter, which constantly provides you with up-to-date information on
your products.

• The right documents via our Search function in Service & Support.

• A forum, where users and experts from all over the world exchange their
experiences.

• Your local representative for Automation & Drives via our representatives
database.

• Information on field service, repairs, spare parts and more under "Services".

http://www.siemens.com/automation/service&support
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1 Tutorial - Introduction

1.1 Overview

Aim of the system commissioning tutorial
Commissioning a plant with PROFInet and PROFIBUS devices involves a number
of different steps (in STEP 7, SIMATIC iMap and on the actual plant).

The aim of this tutorial is to enable you to commission the specimen plant
described in this document.

Content of this tutorial
The tutorial contains

• A description of the overall plant

• Part 1 Instructions for creating the PROFInet components and

• Part 2 Instructions for commissioning the system.

Procedure
The examples described in this tutorial will guide you step-by-step through the
process of commissioning a complex plant. You will use the projects and PROFInet
components supplied to check your progress.

If you use the examples supplied as the basis for further steps, you can be sure
that the commissioning will be carried out correctly.

If you prefer to use off-the-shelf PROFInet components in your SIMATIC iMap
project, then you can start from Part 2: Commissioning the system.
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1.2 Description of the plants
The overall plant is made up of three individual plants. Each plant consists of at
least one PROFInet device with an Ethernet connection. If the PROFInet device is
a PROFIBUS master, the plant may also contain PROFIBUS devices.

Structure of the plants

 Plant  PROFInet device  PROFIBUS device  Function
Plant 1 CPU 315-2DP with a

CP 343-1 PN
Processing station
with conveyor belt

Plant 2 IE/PB Link ET 200S with IM151/CPU
ET 200X with BM147/CPU basic
module

Conveyor station

Plant 3 PC station with
WinLC PN

ET 200S with IM151/CPU
ET 200M with IM153

Processing station
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1.3 Examples supplied

Tutorial install directory
− Depending on the installation − the CBA_Tutorial install directory can be found

• on any path if you download the tutorial to your PC from the Internet or

• in the SIMATIC iMap install directory if you install it together with SIMATIC
iMap version 1.2 or later.

If you download the tutorial from the Internet to your PC, you will find the following
folders with the examples supplied in the tutorial install directory (CBA_Tutorial):

 Folder  Content
S7_Projects STEP7 component projects

You can use these STEP7 projects to create PROFInet
components for plants 1 to 3.

PROFInet_Components Ready-to-use PROFInet components for plants 1 to 3. You can
import these PROFInet components into a SIMATIC iMap
library.

If you install the tutorial together with SIMATIC iMap, you will find the examples
supplied in the following directories:

 Folder  Content
Step7\examples\
ZEn27_04 to _08
(STEP 7 install directory)

STEP7 component projects
You can use these STEP7 projects to create PROFInet
components for plants 1 to 3.

\iMap\CBA_Tutorial\
Components
(iMap install directory)

Ready-to-use PROFInet components for plants 1 to 3. You can
import these PROFInet components into a SIMATIC iMap
library.

Note
The PROFInet component for the IE/PB Link is already included with the SIMATIC
iMap software.

Tip
We recommend that you first complete the individual commissioning steps and
then use the sample projects and PROFInet components supplied as the basis for
further steps to ensure that you complete the commissioning correctly.
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2 Part 1: Creating PROFInet components

2.1 Overview - Creating PROFInet Components
You will need PROFInet components in order to configure a plant with SIMATIC
iMap.

They can be created at any time − regardless of the physical hardware set-up. The
PROFInet components for the plants described here are supplied with the
software, however.

If you use off-the-shelf PROFInet components, you can skip this section and start
directly with Part 2: System Commissioning.

Components for plants 1 to 3

 Plant  PROFInet device  PROFIBUS device  PROFInet component
Plant 1 CPU 315-2DP with a

CP 343-1 PN
Processing_B

Plant 2 IE/PB Link IE-PB-Link1_5MB
ET 200S with IM151/CPU
ET 200X with BM147/CPU
basic module

ET200S_Conveyor
ET200X_Conveyor

Plant 3 PC station with
WinLC PN

Processing_A

ET 200S with IM151/CPU
ET 200M with IM153

ET200S_Conveyor
ET200M_IO
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2.2 Requirements - Creating PROFInet Components
The following software must be installed in order to create PROFInet components
for plants 1 to 3:

• Windows 2000 SP3 or later

• STEP 7 V5.2 or later

• SIMATIC iMap V1.2

• The WinLC PN V1.1 software package must be installed on the local
engineering station (only for plant 3).

Note
You will need administrator rights in order to install SIMATIC iMap.

You will need at least primary user rights in order to use SIMATIC iMap.
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2.3 Basic procedure - Creating PROFInet Components
The PROFInet components are created using STEP 7. The following steps must
be carried out for each PROFInet component:

Tip
We recommend that you first complete the individual steps for creating the
PROFInet components, and then use the S7 projects and PROFInet components
supplied as the basis for further steps to ensure that you complete the
commissioning correctly. The relevant points in the tutorial are indicated by the
following note:

Note
The finished STEP7 component project can be found in the tutorial install directory
under

\CBA_Tutorial\S7_Projects or under Step7\examples\ZEn27_04 to _08
We recommend that you use the project supplied as the basis for further steps to
ensure that you complete the commissioning correctly.
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2.4 Plant 1: Creating PROFInet Components
For plant 1, create the PROFInet component called "Processing_B" from a CPU
315-2DP with CP 343-1PN as the controller for a machining station with conveyor
belt.

The PROFInet component contains:

 PROFInet component  PROFInet device  Technological function
Processing_B CPU 315-2DP with CP

343-1 PN
Processing station with conveyor belt
(S7 program with the component
interface)

Basic procedure
The PROFInet component is created using STEP 7, essentially by applying the
following steps:

1. In SIMATIC Manager, create a project for a component and configure the
station hardware in HWConfig.

2. Create the interface DB for the component interface.

3. Create the S7 program.

4. Create the PROFInet component using a menu command and save it to a
directory.
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Configure the hardware

 Step  Procedure
1. Create a project in SIMATIC Manager and add a Simatic 300 station.
2. Configure the hardware as shown in the following diagram:
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Create the Interface-DB

 Step  Procedure
1. From the PROFInet System Library, copy all the blocks from the "CP 300" block folder to the

CPU block folder.
2. In SIMATIC Manager, open the project block folder and then open DB100.
3. Use the DB100 as the template for the interface DB describing the component interface of the

PROFInet component.
Overwrite the variables and change the attributes as shown in the following diagram:
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 Step  Procedure
4. Check the user-defined attributes in the following declaration lines:

PowerOn

Pad

StandBy

The user-defined attributes are indicated by flags, and are already included in the DB100
template.

Further information...
on the interface DB and user-defined attributes can be found under "Interface DB
properties" in the SIMATIC iMap Basic Help.
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Creating the S7 program

 Step  Procedure
1. Create the S7 program in OB1. The following section from the OB1 is given by way of

example. The sources can be found in the finished STEP7 project.
//refreshing the interface db

   CALL "PN_InOut" , DB41
    LADDR :=W#16#110
    DONE :=M30.0
    ERROR :=M30.1
    STATUS:=MW32

//calling the technological function block "conveyor"
   CALL "CONVEYOR" , DB40
    ExternStop   :="PN_Interface_DB".PowerOn
    ExternStart  :="PN_Interface_DB".ExternReady
    RunDelay    :=
    IOPhotoEye1  :="IO_PhotoEye1"
    IOPhotoEye2  :="IO_PhotoEye2"
    IOPhotoEye3  :="IO_PhotoEye3"
    IOEStop    :=FALSE
    StartNext   :="PN_Interface_DB".StandBy
    Running    :="PN_Interface_DB".Ready
    IOConveyorStart:="IO_ConveyorStart"

//optical signal
   A   "IO_ConveyorStart"
   =   "IO_Signal"

//forwarding the counter value
   L   "PN_Interface_DB".Counter_In
   T   "PN_Interface_DB".Counter_Out

2. Compile and test the S7 program.

Note
The finished STEP7 component project with all the necessary blocks of the S7
program can be found in the tutorial install directory under

\CBA_Tutorial\S7_Projects\300pncp or under Step7\examples\ZEn27_05.

We recommend that you use the project supplied as the basis for further steps to
ensure that you complete the commissioning correctly.
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Create the PROFInet components

 Step  Procedure
1. In SIMATIC Manager, highlight the S7-300 station, and then select Create PROFInet

Component from the context menu.
2. On the "General" tab, highlight the "Identification� New option and enter the following name:

�Processing_B�.
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 Step  Procedure
3. On the "Storage Areas" tab, enter the path D:\cba_tutorial (where D is any drive of your

choice).
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 Step  Procedure
4. On the "Additional Properties" tab, enter the paths of the icon files and the path of the

documentation link.
Use the icons supplied if required (default path: Step7\s7data\s7cbac1x).

Result: The PROFInet component is saved as an XML file and the component
project is saved at the specified storage location.

Note
The finished PROFInet component can be found in the tutorial install directory
under

\CBA_Tutorial\PROFInet_Components\processing_b-{...}

We recommend that you use it as the basis for further steps to ensure that you
complete the commissioning correctly.
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Representation in SIMATIC iMap
In SIMATIC iMap, the PROFInet component as a technological function has the
following appearance:



Part 1: Creating PROFInet components

Component based Automation, Commissioning Systems
A5E00178020-02 2-13

2.5 Plant 2: Creating PROFInet Components
For plant 2, create PROFInet components for the ET 200S and ET 200X devices.

Each PROFInet component contains:

 PROFInet
component

 PROFInet device  PROFIBUS device  Technological function

IE/PB Link IE/PB Link None
ET200S_Conveyor ET 200S with

IM151/CPU
Conveyor station
(S7 program with the
component interface)

ET200X_Conveyor ET 200X with basic
module BM147/CPU

Conveyor station
(S7 program with the
component interface)
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Components supplied and reusability
• PROFInet components with various transmission speeds for the IE/PB Link are

supplied with the SIMATIC iMap software.

• You can also use the PROFInet component "ET200S_Conveyor" for plant 3.

• In the example, "ET200S_Conveyor" and "ET200X_Conveyor" have the same
S7 programs and the same component interfaces, i.e. the requirements and
the procedure are the same for creating both PROFInet components.

2.5.1 Creating the PROFInet Component for ET 200S with IM151/CPU

For plant 2, create the PROFInet component "ET200S_Conveyor" as a controller
for a conveyor belt with ET 200S.

Basic procedure
The PROFInet component is created using STEP 7, essentially by applying the
following steps:

1. In SIMATIC Manager, create a project for a component and configure the
station hardware in HW Config.

2. Create the interface DB for the component interface.

3. Create the S7 program.

4. Create the PROFInet component using a menu command and save it to a
directory.
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Configure the hardware

 Step  Procedure
1. Create a project in SIMATIC Manager and add a Simatic 300 station.
2. Configure the hardware as shown in the following diagram:
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Create the interface DB

 Step  Procedure
1. From the PROFInet System Library, copy all the blocks from the "I-DP slave" block folder to

the CPU block folder.
2. In SIMATIC Manager, open the project block folder and then open DB100.
3. Use the DB100 as the template for the interface DB describing the component interface of the

PROFInet component.
Overwrite the variables and change the attributes as shown in the following diagram:

4. Check the user-defined attributes in the following declaration lines:
ExternStart

Pad

StartNext

The user-defined attributes are indicated by flags, and are already included in the DB100
template.
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Further information...
on the interface DB and user-defined attributes can be found under "Interface DB
properties" in the SIMATIC iMap Basic Help.

Create the S7 program

 Step  Procedure
1. Create the S7 program. The following section from the OB1 is given by way of example. The

sources can be found in the finished STEP7 project.
//refreshing the input section of the interface db
   CALL "PN_IN"
    DB_NO :="PN_IO_DB"
    RET_VAL:=MW20
//calling the technological function block "conveyor"
   CALL "CONVEYOR" , DB40
    ExternStop   :="PN_Interface_DB".ExternStart
    ExternStart  :="PN_Interface_DB".ExternStop
    RunDelay    :="PN_Interface_DB".RunDelay
    IOPhotoEye1  :="IO_PhotoEye1"
    IOPhotoEye2  :="IO_PhotoEye2"
    IOPhotoEye3  :="IO_PhotoEye3"
    IOEStop    :=FALSE
    StartNext   :=DB100.DBX8.0
    Running    :=DB100.DBX8.1
    IOConveyorStart:="IO_ConveyorStart"

//forwarding the counter value
   L   "PN_Interface_DB".Counter_In
   T   "PN_Interface_DB".Counter_Out

//optical signal
   U   "IO_ConveyorStart"
   =   "IO_Signal"

//refreshing the output section of the interface db
   CALL "PN_OUT"
    DB_NO :="PN_IO_DB"
    RET_VAL:=MW22

2. Compile and test the S7 program.

Attention
Please note that the PN_IN (FC10) block at the start of the OB1 and the PN_OUT
(FC11) block at the end of the OB1 both have to be called.



Part 1: Creating PROFInet components

Component based Automation, Commissioning Systems
2-18 A5E00178020-02

Note
The finished STEP7 component project with all the necessary blocks of the S7
program can be found in the tutorial install directory under

\CBA_Tutorial\S7_Projects\Et200s or under Step7\examples\ZEn27_06.

We recommend that you use the project supplied as the basis for further steps to
ensure that you complete the commissioning correctly.

Create the PROFInet component

 Step  Procedure
1. In SIMATIC Manager, highlight the Simatic 300 station, and then select Create PROFInet

Component from the context menu.
2. On the "General" tab, highlight the "Identification" New option and enter the following name:

"ET200S_Conveyor�.
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 Step  Procedure
3. On the "Storage Areas" tab, enter the path D:\cba_tutorial (where D is any drive of your

choice).
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 Step  Procedure
4. On the "Additional Properties" tab, enter the paths of the icon files and the path of the

documentation link.
Use the icons supplied if required (default path: Step7\s7data\s7cbac1x).

Result: The PROFInet component is saved as an XML file and the component
project is saved at the specified storage location.

Note
The finished PROFInet component can be found in the tutorial install directory
under

\CBA_Tutorial\S7_Projects\Et200s.

We recommend that you use it as the basis for further steps to ensure that you
complete the commissioning correctly.
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Representation in SIMATIC iMap
In SIMATIC iMap, the PROFInet component as a technological function has the
following appearance:

2.5.2 Creating the PROFInet Component for ET 200X with BM147/CPU

For plant 2, create the PROFInet component "ET200X_Conveyor" as a controller
for a conveyor belt with ET 200X.

In the example, "ET200X_Conveyor" and "ET200X_Conveyor" have the same S7
programs and the same component interfaces, i.e. the requirement and procedure
for creating the PROFInet component are the same as for ET 200S with
IM151/CPU.

Basic procedure
The PROFInet component is created using STEP 7, essentially by applying the
following steps:

1. In SIMATIC Manager, create a project for a component and configure the
station hardware in HWConfig.

2. Create the interface DB for the component interface.

3. Create the S7 program.

4. Create the PROFInet component using a menu command and save it to a
directory.
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Configure the hardware

 Step  Procedure
1. Create a project in SIMATIC Manager and add a Simatic 300 station.
2. Configure the hardware as shown in the following diagram:
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Creating the Interface DB

 Step  Procedure
1. From the PROFInet System Library, copy all the blocks from the "I-DP slave" block folder to

the CPU block folder.
2. In SIMATIC Manager, open the project block folder and then open DB100.
3. Use the DB100 as the template for the interface DB describing the component interface of the

PROFInet component.
Overwrite the variables and change the attributes as shown in the following diagram:

4. Check the user-defined attributes in the following declaration lines:
ExternStart

Pad

StartNext

The user-defined attributes are indicated by flags, and are already included in the DB100
template.

Further information...
on the interface DB and user-defined attributes can be found under "Interface DB
properties" in the SIMATIC iMap Basic Help.
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Create the S7 program

 Step  Procedure
1. Create the S7 program. The following section from the OB1 is given by way of example. The

sources can be found in the finished STEP7 project.
//refreshing the input section of the interface db
   CALL "PN_IN"
    DB_NO :="PN_IO_DB"
    RET_VAL:=MW20
//calling the technological function block "conveyor"
   CALL "CONVEYOR" , DB40
    ExternStop   :="PN_Interface_DB".ExternStart
    ExternStart  :="PN_Interface_DB".ExternStop
    RunDelay    :="PN_Interface_DB".RunDelay
    IOPhotoEye1  :="IO_PhotoEye1"
    IOPhotoEye2  :="IO_PhotoEye2"
    IOPhotoEye3  :="IO_PhotoEye3"
    IOEStop    :=FALSE
    StartNext   :=DB100.DBX8.0
    Running    :=DB100.DBX8.1
    IOConveyorStart:="IO_ConveyorStart"

//forwarding the counter value
   L   "PN_Interface_DB".Counter_In
   T   "PN_Interface_DB".Counter_Out

//optical signal
   U   "IO_ConveyorStart"
   =   "IO_Signal"

//refreshing the output section of the interface db
   CALL "PN_OUT"
    DB_NO :="PN_IO_DB"
    RET_VAL:=MW22

2. Compile and test the S7 program.

Attention
Please note that the PN_IN (FC10) block at the start of the OB1 and the PN_OUT
(FC11) block at the end of the OB1 both have to be called.
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Note
The finished STEP7 component project with all the necessary blocks of the S7
program can be found in the tutorial install directory under

\CBA_Tutorial\S7_Projects\Et200x or under Step7\examples\ZEn27_07.

We recommend that you use the project supplied as the basis for further steps to
ensure that you complete the commissioning correctly.

Create the PROFInet component

 Step  Procedure
1. In SIMATIC Manager, highlight the Simatic 300 station, and then select Create PROFInet

Component from the context menu.
2. On the "General" tab, select the "Identification" New option and enter "ET200X_Conveyor" as

the name.
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 Step  Procedure
3. On the "Storage Areas" tab, enter the path D:\cba_tutorial (where D is any drive of your

choice).



Part 1: Creating PROFInet components

Component based Automation, Commissioning Systems
A5E00178020-02 2-27

 Step  Procedure
4. On the "Additional Properties" tab, enter the paths of the icon files and the path of the

documentation link.
Use the icons supplied if required (default path: Step7\s7data\s7cbac1x).

Result: The PROFInet component is saved as an XML file and the component
project is saved at the specified storage location.

Note
The finished PROFInet component can be found in the tutorial install directory
under

\CBA_Tutorial\PROFInet_Components\et200x_conveyor-{...}

We recommend that you use it as the basis for further steps to ensure that you
complete the commissioning correctly.
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Representation in SIMATIC iMap
In SIMATIC iMap, the PROFInet component as a technological function has the
following appearance:
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2.6 Plant 3: Creating PROFInet Components
For plant 3, create PROFInet components for the PC station with WinLC PN and
for the ET 200S with IM151/CPU and ET 200M
devices.

Each PROFInet component contains:

 PROFInet
component

 PROFInet device  PROFIBUS
device

 Technological function

Processing_A PC station with
WinLC PN

Processing station
(S7 program with the
component interface)

ET200S_Conveyor ET 200S with
IM151/CPU

Conveyor station
(S7 program with the
component interface)

 ET200M_IO ET 200M with
IM153

Component interface only
(see below)
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Note
You can use the PROFInet component "ET200S_Conveyor" from plant 2 for plant
3 as well.

2.6.1  Creating the PROFInet Component for WinLC PN

For plant 3, create the PROFInet component "Processing_A" as the coordinator for
several conveyor systems.

Basic procedure
The PROFInet component is created using STEP 7, essentially by applying the
following steps:

1. In SIMATIC Manager, create a project for a component and configure the
station hardware in HWConfig.

2. Create the interface DB for the component interface.

3. Create the S7 program.

4. Create the PROFInet component using a menu command and save it to a
directory.
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Configure the hardware

 Step  Procedure
1. Create a project in SIMATIC Manager and add a Simatic PC station.
2. Configure the hardware as shown in the following diagram:
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Create the Interface DB

 Step  Procedure
1. From the PROFInet System Library, copy all the blocks from the "WinLC PN" block folder to the

block folder for the WinLC PN.
2. In SIMATIC Manager, open the project block folder and then open DB100.
3. Use the DB100 as the template for the interface DB describing the component interface of the

PROFInet component.
Overwrite the variables and attributes as shown in the following diagram:
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 Step  Procedure
4. Check the user-defined attributes in the following declaration lines:

PowerOn

Pad

StandBy

The user-defined attributes are indicated by flags, and are already included in the DB100
template.

Further information...
on the interface DB and user-defined attributes can be found under "Interface DB
properties" in the SIMATIC iMap Basic Help.
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Create the S7 program

 Step  Procedure
1. Create the program. The following section from the OB1 is given by way of example. The

sources can be found in the finished STEP7 project.
//forwards RunDelay to ORunDelay
   L   "PN_Interface_DB".RunDelay
   T   "PN_Interface_DB".RunDelay_Out

//forwards EStop to OEStop
   U   "PN_Interface_DB".HMIStop
   =   "PN_Interface_DB".HMIStop_Out

//increments OCnt if Cnt==OCnt
   L   "PN_Interface_DB".Counter_In
   L   "PN_Interface_DB".Counter_Out
   <>D
   SPB  GO
   L   "PN_Interface_DB".Counter_Out
   L   1
   +D
   T   "PN_Interface_DB".Counter_Out
GO:  NOP  0

2. Compile and test the S7 program.

Note
The finished STEP7 component project with all the necessary blocks of the S7
program can be found in the tutorial install directory under

\CBA_Tutorial\S7_Projects\WinLC or under Step7\examples\ZEn27_04.

We recommend that you use the project supplied as the basis for further steps to
ensure that you complete the commissioning correctly.
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Create the PROFInet component

 Step  Procedure
1. In SIMATIC Manager, highlight the Simatic PC station, and then select Create PROFInet

Component from the context menu.
2. On the "General" tab, highlight the "Identification" New option and enter the following name:

"Processing_B�.
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 Step  Procedure
3. On the "Storage Areas" tab, enter the path D:\cba_tutorial (where D is any drive of your

choice).
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 Step  Procedure
4. On the "Additional Properties" tab, enter the paths of the icon files and the path of the

documentation link.
Use the icons supplied if required (default path: Step7\s7data\s7cbac1x).

Result: The PROFInet component is saved as an XML file and the component
project is saved at the specified storage location.

Note
The finished PROFInet component can be found in the tutorial install directory
under

\CBA_Tutorial\PROFInet_Components\processing_a-{...}

We recommend that you use it as the basis for further steps to ensure that you
complete the commissioning correctly.
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Representation in SIMATIC iMap
In SIMATIC iMap, the PROFInet component as a technological function has the
following appearance:

2.6.2 Creating the PROFInet Component for ET 200S with IM151/CPU

For plant 2, create the PROFInet component "ET200S_Conveyor" as a controller
for a conveyor belt with ET 200S.

Basic procedure
The PROFInet component is created using STEP 7, essentially by applying the
following steps:

1. In SIMATIC Manager, create a project for a component and configure the
station hardware in HW Config.

2. Create the interface DB for the component interface.

3. Create the S7 program.

4. Create the PROFInet component using a menu command and save it to a
directory.
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Configure the hardware

 Step  Procedure
1. Create a project in SIMATIC Manager and add a Simatic 300 station.
2. Configure the hardware as shown in the following diagram:
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Create the interface DB

 Step  Procedure
1. From the PROFInet System Library, copy all the blocks from the "I-DP slave" block folder to

the CPU block folder.
2. In SIMATIC Manager, open the project block folder and then open DB100.
3. Use the DB100 as the template for the interface DB describing the component interface of the

PROFInet component.
Overwrite the variables and change the attributes as shown in the following diagram:

4. Check the user-defined attributes in the following declaration lines:
ExternStart

Pad

StartNext

The user-defined attributes are indicated by flags, and are already included in the DB100
template.
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Further information...
on the interface DB and user-defined attributes can be found under "Interface DB
properties" in the SIMATIC iMap Basic Help.

Create the S7 program

 Step  Procedure
1. Create the S7 program. The following section from the OB1 is given by way of example. The

sources can be found in the finished STEP7 project.
//refreshing the input section of the interface db
   CALL "PN_IN"
    DB_NO :="PN_IO_DB"
    RET_VAL:=MW20
//calling the technological function block "conveyor"
   CALL "CONVEYOR" , DB40
    ExternStop   :="PN_Interface_DB".ExternStart
    ExternStart  :="PN_Interface_DB".ExternStop
    RunDelay    :="PN_Interface_DB".RunDelay
    IOPhotoEye1  :="IO_PhotoEye1"
    IOPhotoEye2  :="IO_PhotoEye2"
    IOPhotoEye3  :="IO_PhotoEye3"
    IOEStop    :=FALSE
    StartNext   :=DB100.DBX8.0
    Running    :=DB100.DBX8.1
    IOConveyorStart:="IO_ConveyorStart"

//forwarding the counter value
   L   "PN_Interface_DB".Counter_In
   T   "PN_Interface_DB".Counter_Out

//optical signal
   U   "IO_ConveyorStart"
   =   "IO_Signal"

//refreshing the output section of the interface db
   CALL "PN_OUT"
    DB_NO :="PN_IO_DB"
    RET_VAL:=MW22

2. Compile and test the S7 program.

Attention
Please note that the PN_IN (FC10) block at the start of the OB1 and the PN_OUT
(FC11) block at the end of the OB1 both have to be called.
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Note
The finished STEP7 component project with all the necessary blocks of the S7
program can be found in the tutorial install directory under

\CBA_Tutorial\S7_Projects\Et200s or under Step7\examples\ZEn27_06.

We recommend that you use the project supplied as the basis for further steps to
ensure that you complete the commissioning correctly.

Create the PROFInet component

 Step  Procedure
1. In SIMATIC Manager, highlight the Simatic 300 station, and then select Create PROFInet

Component from the context menu.
2. On the "General" tab, highlight the "Identification" New option and enter the following name:

"ET200S_Conveyor�.
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 Step  Procedure
3. On the "Storage Areas" tab, enter the path D:\cba_tutorial (where D is any drive of your

choice).
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 Step  Procedure
4. On the "Additional Properties" tab, enter the paths of the icon files and the path of the

documentation link.
Use the icons supplied if required (default path: Step7\s7data\s7cbac1x).

Result: The PROFInet component is saved as an XML file and the component
project is saved at the specified storage location.

Note
The finished PROFInet component can be found in the tutorial install directory
under

\CBA_Tutorial\S7_Projects\Et200s.

We recommend that you use it as the basis for further steps to ensure that you
complete the commissioning correctly.
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Representation in SIMATIC iMap
In SIMATIC iMap, the PROFInet component as a technological function has the
following appearance:

2.6.3 Creating the PROFInet Component for ET 200M

For plant 3, create the PROFInet component "ET200M_IO" as an I/O module.

Note
The PROFInet component ET200M_IO does not contain an S7 program. It only
contains the component interface: the signal inputs are mapped directly onto the
outputs of the technological function and the signal outputs onto the inputs of the
technological function.

Basic procedure
The PROFInet component is created using STEP 7, essentially by applying the
following steps:

1. In SIMATIC Manager, create a project for a component and configure the
station hardware in HWConfig.

2. Create the interface DB for the component interface.

3. Create the S7 program.

4. Create the PROFInet component using a menu command and save it to a
directory.
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Configure the hardware

 Step  Procedure
1. Create a project in SIMATIC Manager and add a Simatic 300 station.
2. Configure the hardware as shown in the following diagram:

The I/O modules of IM 153-2 are important.

Note
The CPU (DP master) is not part of the PROFInet component to be created, so it is
not displayed in SIMATIC iMap. It is needed in HW Config, however, for
configuration purposes.
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Create the Interface DB

 Step  Procedure
1. From the PROFInet System Library, copy all the blocks from the "DP slave" block folder to the

CPU 315-2DP block folder.
2. For the interface DB of the PROFInet component for ET 200M, note that:

• the inputs are mapped onto the addresses of the outputs,
• the outputs are mapped onto the addresses of the inputs.

3. Use the DB100 as the template for the interface DB. Follow the rules for the interface DB (see
Basic help for SIMATIC iMap, Creating PROFInet components with STEP 7).
Overwrite the variables and change the attributes as shown in the following diagram:

4. Check the user-defined attributes in the following declaration lines:
Input1

Output1

The user-defined attributes are indicated by flags, and are already included in the DB100
template.

Further information...
on the interface DB and user-defined attributes can be found under "Interface DB
properties" in the SIMATIC iMap Basic Help.
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Create the S7 program
The ET 200M does not require a separate S7 program since it is a module without
its own PLC (CPU).

Note
The finished STEP7 component project with all the necessary blocks of the S7
program can be found in the tutorial install directory under

\CBA_Tutorial\S7_Projects\Et200m or under Step7\examples\ZEn27_08.

We recommend that you use the project supplied as the basis for further steps to
ensure that you complete the commissioning correctly.
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Create the PROFInet component

 Step  Procedure
1. In SIMATIC Manager, highlight the Simatic PC station, and then select Create PROFInet

Component from the context menu.
2. On the "General" tab:

• Highlight the "Create component from a slave" option and select the appropriate interface
DB, e.g. DB100, from the drop-down list.

• Highlight the "Identification" New option and enter the following name: "ET200M_IO".
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 Step  Procedure
3. On the "Storage Areas" tab, enter the path D:\cba_tutorial (where D is any drive of your

choice).
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 Step  Procedure
4. On the "Additional Properties" tab, enter the paths of the icon files and the path of the

documentation link.
Use the icons supplied if required (default path: Step7\s7data\s7cbac1x).

Result: The PROFInet component is saved as an XML file and the component
project is saved at the specified storage location.

Note
The finished PROFInet component can be found in the tutorial install directory
under

\CBA_Tutorial\PROFInet_Components\et200m_io-{...}

We recommend that you use it as the basis for further steps to ensure that you
complete the commissioning correctly.
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Representation in SIMATIC iMap
In SIMATIC iMap, the PROFInet component as a technological function has the
following appearance:
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3 Part 2: Commissioning the system

Commissioning a complex plant with PROFInet and PROFIBUS devices involves a
large number of tasks. The following description guides you step-by-step through
the process of commissioning three typical configurations (plants 1 to 3).

3.1 Requirements - Commissioning the system

Hardware requirements
The devices must be in working order and have the latest firmware.

Tip
In the following descriptions, the devices are assigned fixed IP and PROFIBUS
addresses. If commissioning is to be successful, we recommend that you use the
same addresses since they are used throughout all the examples supplied.

For the plant described here, all the IP addresses must be in the same subnet.

Software requirements
The following software must be installed on the engineering station:

• Windows 2000 SP3 or later

• STEP 7 V5.2 or later

• SIMATIC iMap V1.2

• SIMATIC NET V6.0 SP6

Note
You will need administrator rights in order to install SIMATIC iMap.

You will need at least primary user rights in order to use SIMATIC iMap.

Requirement for configuring the plants in SIMATIC iMap
You must have created the PROFInet components and they must either be present
in the file system or located in the tutorial install directory under

iMap\CBA_Tutorial\components



Part 2: Commissioning the system

Component based Automation, Commissioning Systems
3-2 A5E00178020-02

3.2 Basic procedure: Commissioning the system
The following commissioning tasks are carried out for every device in a plant:

• On the plant:

- Set up the hardware

- Set addresses on the PROFIBUS devices

- Network the device and link to engineering PC

• In STEP 7:

- Assign IP addresses for the first time, if necessary

- Make the download, online monitoring and diagnostics settings

• In SIMATIC iMap:

- Configure the plant

- Start the plant

- Monitor the plant online and diagnose

Next steps
Start up one of the following plants:

• Plant 1: A CPU 315-2DP with CP 343-1 PN

• Plant 2: An IE/PB Link with the PROFIBUS devices ET 200S with IM151/CPU
and ET 200X with BM147/CPU

• Plant 3: A PC station WinLC PN with the PROFIBUS devices ET 200S with
IM151/CPU and ET 200M

• Overall plant consisting of plants 1 to 3
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3.3 Plant 1: CPU 315 with CP 343-1 PN
Plant 1 consists of one PROFInet component. In the following example, this
PROFInet component is the controller for a processing station with conveyor belt.

The PROFInet component contains:

• the PROFInet device, consisting of a CPU 315-2 DP, a CP 343-1 PN and the
associated I/O modules

• the technological function "Processing_B", consisting of the S7 program with
the component interface.

Basic procedure
The following tasks must be carried out:

1. Set up the plant hardware.

2. Configure the plant in SIMATIC iMap.

3. Assign an IP address to the device for the first time

4. Check your settings in STEP 7 in order to download the project data from
SIMATIC iMap to the device and be able to monitor the plant online.

5. Start the plant

6. Monitor the plant online with SIMATIC iMap.
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3.3.1 Step 1: Set up hardware

Hardware required
You will need the following S7-300 modules:

 Quantity  Designation  Order no.
1 x CPU 315-2DP 6ES7 315-2AF03-0AB0
1 x Power supply unit PS 307 5A 6ES7 307-1EA00-0AA0
1 x Communication processor CP 343-1 PN 6GK7 343-1HX00-0XE0
1 x I/O modules DI8/DO8xDC24V/0.5A 6ES7 323-1BH01-0AA0

 Step  Procedure
1. Attach the modules to the rail

Connect the CP 343-1 PN to the backplane bus via the bus connector.
2. Connect the power supply.
3. Wire up the I/O modules.
4. Connect the Ethernet cable to the CP 343-1 PN.

3.3.2 Step 2: Configure Plant 1 in SIMATIC iMap

Requirements
You must have created the PROFInet components and they must either be present
in the file system or located in the tutorial install directory under

iMap\CBA_Tutorial\components.

Basic procedure
1. Create a library in SIMATIC iMap, if it does not exist.

2. Import the PROFInet component from the file system to the library.

3. Paste the PROFInet component from the library to the SIMATIC iMap project
and assign addresses

4. Interconnect the technological functions, if necessary, and generate the
SIMATIC iMap project.
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Create a Library in SIMATIC iMap

 Step  Procedure
1. Start SIMATIC iMap:

• by double-clicking the  icon or
• by selecting Start > Programs > Component based Automation > SIMATIC iMap.

2. Select the Library > New... menu command.
3. Under �Search in�, select the path Programs\Siemens\iMap\Tutorial.
4. Crate a new folder named "libs"
5. In the "libs" folder, create a library with the file name "tutorial_lib�.



Part 2: Commissioning the system

Component based Automation, Commissioning Systems
3-6 A5E00178020-02

 Step  Procedure
6. Click on the "Save" button to confirm your input.

Result: The library called "tutorial_lib" is created and opened in SIMATIC iMap.

Plant 1: Import PROFInet Component

 Step  Procedure
1. In SIMATIC iMap, click in the "tutorial_lib" library window.

If the "tutorial_lib" library is not open, open it by selecting Library > Open
2. Import the PROFInet component from the file system to the library:

Select Import Component from the context menu in the library window.
3. Under "Search In", select the path Programs\Siemens\iMap\CBA_Tutorial\components.
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 Step  Procedure
4. Select the "processing_b--{...}" folder.

5. Select the "Processing_B.xml" file from this folder and click on the "Open" button to confirm.
Result: The PROFInet component "Processing_B" is added to the library.
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Plant 1: Paste PROFInet Component into the Project and Assign Addresses

 Step  Procedure
1. Insert the PROFInet component into the project:

Select "Processing_B" from the library, then select Paste into Project from the context menu.
The PROFInet device is automatically linked to the Ethernet in the network view.

The technological function is displayed in the plant view:

2. Optional − Repeat step 1 for other PROFInet components, e.g. ET200X_Conveyor.
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 Step  Procedure
3. In the network view, select the CPU 315-2 DP device and select the Properties... context

menu.
Enter the IP address and subnet mask in the "Properties" dialog for the PROFInet device.
Note: The IP address and subnet mask must be exactly the same as those that you entered
for the device in STEP7.
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Interconnect Technological Functions and Generate the Project

 Step  Procedure
1. Interconnection is not necessary for plant 1 since the project only contains one PROFInet

component.
2. Make sure that the �tutorial_lib� library is open.

Generate the project:
• using the Project > Generate > Changes Only menu command or

• by clicking on the "Generate" icon .
If you have not yet saved the project, you will be prompted to enter a name for the project. In
the "Save Simatic iMap Project As" dialog box, select a path and enter a name, e.g. "Plant_1".
Result: The project is saved and generated.

3. You can follow the generation progress in the information window.

Result: The plant is configured and can now be started.
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3.3.3 Step 3: Assign an IP address to the CP 343-1 PN for the first time

Requirements
• The IP address of the CP 343-1PN must be known.

• The connection to the Ethernet LAN must be established; there must be no
subnet transition (router) between the two.

• It must be possible to access the Ethernet interface of your PG/PC from STEP
7; the PG/PC interface must be set as follows:
S7ONLINE [STEP 7] > TCP/IP > <network module>
To set the PG/PC interface, select Options > Set PG/PC interface... in
SIMATIC Manager or select Start > Simatic > SIMATIC NET > Settings > Set
PG-PC interface from the Windows taskbar

.

• The DLC protocol (Data Link Control) must be installed on the Ethernet
interface. If the DLC protocol is not installed on your PG/PC, call up the
network settings (via Control Panel > Network > Protocols) and install the
DLC protocol for your Ethernet connection.
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Procedure

 Step  Procedure
1. Open SIMATIC Manager.
2. Select PLC > Assign Ethernet Address

3. Click on the "Browse...� button to search the network for accessible modules.
All accessible stations on the network are displayed.
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 Step  Procedure
4. Select the CP with the right MAC address from list of the suggested components.

5. Enter the IP parameters as shown in the following diagram, and assign them to the CP.
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3.3.4 Step 4: Check the Necessary Settings on the Engineering Station
for Plant 1

Requirements
• See chapter "Requirements - Commissioning the system"

• The PG/PC is linked to the CP 343-1 PN via the Ethernet.

Procedure

 Step  Procedure
1. Select Start > Simatic > SIMATIC NET > Settings >PG/ PC Interface and check the following

setting:
"TCP/IP" is set as the access point for the "S7ONLINE (STEP 7)" application.

2. Select Start > Simatic > SIMATIC NET > Settings > Set PC Station.
The configuration console opens.
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 Step  Procedure
3. Select the computer's Ethernet module from the "Structure" window.

"PG mode" must be set as the operating mode under "General".

4. Confirm any changes and close the configuration console.

For plants with WinLC PN
If you are using a WinLC PN, please note the following point:

If STEP 7, SIMATIC iMap and WinLC PN are on a computer - the local engineering
station - then the settings for plant 3-2 apply, rather than those specified above.
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3.3.5 Step 5: Commissioning Plant 1

Requirements
• See chapter "System commissioning requirements"

• The PG/PC is linked to the CP 343-1 PN via the Ethernet.

• You have checked the settings on the engineering station.

• You have generated the project in SIMATIC iMap.

• All the devices are switched on.

Tip: Check the generation status
To check the generation status of the device, open the properties

• of the device in the network view

• of the technological function in the plant view.

The generation status must be "Generated". If this is not the case, generate the
project again using the Project > Generate > Changes Only menu command.
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Procedure

 Step  Procedure
1. In SIMATIC iMap, select

• the device from the network view or
• the technological function from the plant view
and download the data to the device:
Select Download > Selected Devices > All from the context menu.

2. If the CP 343-1 PN is in RUN mode, you are asked whether you wish to stop the device.
Click on "Yes" to confirm the message.
Result: The device switches to STOP and the data is downloaded to the device.
You are then asked whether you want to restart the device.
Click on "Yes" to confirm the message.

Result: The device is ready for use.
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3.3.6 Step 6: Monitor Plant 1 Online

With SIMATIC iMap, you can

• monitor online and diagnose the devices of the plant.

• display and set online values.

Requirements
• See chapter "System commisioning requirements"

• The PG/ PC is linked to the PROFInet device or one of the PROFInet devices
via the Ethernet.

• You have checked the settings in STEP 7.

• You have generated the project in SIMATIC iMap.

• You have downloaded the data to the device.

• The device is in RUN mode.
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Procedure

 Step  Procedure
1. Switch the online view on/off

In SIMATIC iMap, switch on the online view:

• click on the "Online Monitoring" icon  or
• select Online > Monitor.
You are asked whether you want to compare the devices' online and offline program data. This
comparison is optional. You can run it immediately or later.
If you answer "Yes" to this question, the data is compared and the result is displayed in the
information window.
Result: The SIMATIC iMap online view is switched on and any diagnostic information is
displayed directly at the devices and technological functions and in the diagnostic window.
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 Step  Procedure
2. Display Online Values

In the project plant view, select the "CounterIn" input and then select the Display Online Values
menu command from the context menu. The online value 0 is displayed since the connector is
not interconnected.

3. 
Click again on the  icon or select the Online > Monitor option to switch off the online view.

Display diagnostic information
In the event of an error, diagnostic information is displayed in SIMATIC iMap in
both graphical and text format.

The diagnostic information for the technological functions can be found on the
"Functions" tab in the diagnostic window.
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Example: The interconnections have to be downloaded (Online > Download
Selected Device > Interconnection Only menu command).

The diagnostic information for the devices can be found on the "Devices" tab in the
diagnostic window.

Example: The device is not available. In this case, you will have to check the
settings and the communication links.
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3.4 Plant 2: IE/PB Link with PROFIBUS DP slaves
Plant 2 consists of the following devices:

• An IE/PB Link PROFInet device as the DP master with proxy functionality for
the following PROFIBUS devices:

• ET 200S with IM 151/CPU as the intelligent DP slave for controlling a conveyor
belt "ET200S_Conveyor"

• ET 200X with BM147/CPU as an intelligent DP slave for controlling a conveyor
belt "ET200X_Conveyor"
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Basic procedure
The following tasks must be carried out:

1. Set up the plant hardware:

- IE/PB Link

- ET 200S with IM151/CPU

- ET 200X with BM147/CPU

2. Configure the plant in SIMATIC iMap.

3. Assign addresses

- Assign an IP address to the IE/PB Link for the first time.

- Assign a PROFIBUS address to the IM151/CPU for the first time.

4. Check your settings in STEP 7 in order to download the project data from
SIMATIC iMap to the devices of the plant and be able to monitor the plant
online.

5. Start the plant

6. Monitor the plant online with SIMATIC iMap.
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3.4.1 Step 1: Set up hardware

3.4.1.1 ET 200S with IM151/CPU Hardware Set-up

Hardware required
You will need the following modules:

 Quantity  Designation  Order no.
1 x Interface module IM 151 and terminating

module, 1x
6ES7 151-7AA10-0AB0 / V2.0

2 x Terminal module TM-P15S23-A1, 1x 6ES7 193-4CC30-0AA0
2 x Terminal module TM-E15S24-A1, 5x 6ES7 193-4CA20-0AA0
2 x Power module PM-E DC24 V, 1x 6ES7 138-4CA00-0AA0
1 x 2DI DC24V; high feature, 2x 6ES7 131-4BB00-0AB0
1 x 2DO DC24V; 0.5 A; high feature, 2x 6ES7 132-4BB00-0AB0
1 x Bus connector 6ES7 972-0BA10-0XA0

Procedure

 Step  Procedure
1. Attach the modules to the rail
2. Connect the power supply.
3. Wire up the I/O modules.
4. Connect the PG/PC to the IM151/CPU using the PG cable.
5. Switch on the power supply to the IM151/CPU.

Note
When you start up the ET 200S for the first time (as-delivered state), the
IM151/CPU can be accessed via MPI addresses 2, HSA 31 and 187.5 kBps. The
PROFIBUS address is assigned to the IM 151/CPU via MPI after the project is
generated in SIMATIC iMap.



Part 2: Commissioning the system

Component based Automation, Commissioning Systems
A5E00178020-02 3-25

3.4.1.2 ET 200X with BM147/CPU Hardware Set-up

Hardware required
You will need the following modules:

 Quantity  Designation  Order no.
1 x Basic module BM147/CPU 6ES7 147-1AA01-0XB0
1 x Expansion module DI 4xDC24V 6ES7 141-1BD30 - 0XA0
1 x Expansion module DO 4xDC24V/2A 6ES7 141-1BD40 - 0XA0

Procedure

 Step  Procedure
1. Attach the modules to the rail
2. Set PROFIBUS address 18 on the BM 147/CPU basic module.
3. Connect the power supply.
4. Wire up the I/O modules.
5. Connect the IE/PB Link to the BM 147/CPU using the PROFIBUS cable.
6. Switch on the IE/PB Link if you have not already done so.

3.4.1.3 IE/PB Link Hardware Set-up

Hardware required
1 IE/PB Link network transition with the necessary accessories (see device
manual).

Procedure

 Step  Procedure
1. Attach the modules to the rail
2. Connect the power supply.
3. Connect the IE/PB Link to the Ethernet and PROFIBUS.
4. Switch on the power supply.
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3.4.2 Step 2: Configure Plant 2 in SIMATIC iMap

Requirements
You must have created the PROFInet components and they must either be present
in the file system or located in the tutorial install directory under

iMap\CBA_Tutorial\components.

Basic procedure
1. Create a library in SIMATIC iMap, if it does not exist.

2. Import the PROFInet components from the file system to the library.

3. Paste the PROFInet components from the library into the SIMATIC iMap
project.

4. Assign addresses in SIMATIC iMap .

5. Interconnect technological functions and generate SIMATIC iMap project.

 Create a Library in SIMATIC iMap

 Step  Procedure
1. Start SIMATIC iMap:

• by double-clicking the  icon or
• by selecting Start > Programs > Component based Automation > SIMATIC iMap.

2. Select the Library > New... menu command.
3. Under �Search in�, select the path Programs\Siemens\iMap\Tutorial.
4. Crate a new folder named "libs"
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 Step  Procedure
5. In the "libs" folder, create a library with the file name "tutorial_lib�.

6. Click on the "Save" button to confirm your input.
Result: The library called "tutorial_lib" is created and opened in SIMATIC iMap.
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Import PROFInet Components

 Step  Procedure
1. In SIMATIC iMap, click in the "tutorial_lib" library window.

If the "tutorial_lib" library is not open, open it by selecting Library > Open
2. Import the PROFInet components from the file system to the library:

Select Import Component from the context menu in the library window.
3. Under "Search In", select the path Programs\Siemens\iMap\CBA_Tutorial\components.
4. Select the "et200s_conveyor--{...}" folder.

5. From this folder, select the "ET200S_Conveyor.xml" file and click on the "Open" button to
confirm your input.
Result: The PROFInet component "ET200S_Conveyor" is added to the library.

6. Repeat steps 2 to 5 for the PROFInet component "ET200X_Conveyor" ("et200x_conveyor--{...}
folder and "ET200X_Conveyor.xml" file).
Result: The PROFInet component "ET200X_Conveyor" is added to the library.
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 Step  Procedure
7. Repeat steps 2 to 5 for the off-the-shelf PROFInet component of the IE/PB Link, which can be

found under imap\components\IE-PB-Link_PN_1,5MBaud-{} in the SIMATIC iMap install
directory. Select the file called "IE-PB-Link PN 1_5MBaud.xml".
Result: The PROFInet component "IE-PB-Link PN 1_5MBaud" is added to the library.
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Paste PROFInet Components into the Project

 Step  Procedure
1. Paste the PROFInet component for the IE/PB Link into the project:

Select the PROFInet component "IE-PB-Link 1_5MB" from the library and
• drag it into the network view or
• select Paste Into Project from the context menu.
The PROFInet device is automatically linked to the Ethernet in the network view, and has a
PROFIBUS connector as the DP master with proxy functionality.

2. Select the PROFInet component "ET200S_Conveyor" from the library, then use Drag&Drop to
link it to the PROFIBUS of the IE/PB Link.
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 Step  Procedure
3. Repeat step 2 for the PROFInet component "ET200X_Conveyor".
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Assign Addresses

 Step  Procedure
1. In the network view, open the IE/PB Link properties and enter the IP address and subnet

mask, plus the PROFIBUS address of the device on the "Addresses" tab.
Note: You assign exactly the same addresses to the device in step 3.
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 Step  Procedure
2. In the network view, open the properties of the PROFIBUS device "IM151_CPU" (ET 200S)

and enter the device's PROFIBUS address on the "Addresses" tab.
Note: You assign exactly the same address to the device via MPI (see Assign a PROFIBUS
address to the IM 151/CPU for the first time).



Part 2: Commissioning the system

Component based Automation, Commissioning Systems
3-34 A5E00178020-02

 Step  Procedure
3. Repeat step 2 for "BM147_CPU" and assign PROFIBUS address 18 to the device. This must

be the address that is set on the device's DIL switch.
The network view for plant 2 then has the following appearance:

Interconnect Technological Functions and Generate Project

 Step  Procedure
1. Open the plant view. At first, the technological functions are arranged one above the other.
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 Step  Procedure
2. Arrange the technological functions and interconnect them as shown below:

3. Make sure that the �tutorial_lib� library is open.
Generate the project:
• using the Project > Generate > Changes Only menu command or

• by clicking on the "Generate" icon .
If you have not yet saved the project, you will be prompted to enter a name for the project. In
the "Save Simatic iMap Project As" dialog box, select a path and enter a name, e.g. "Plant 2".
Result: The project is saved and generated.

4. You can follow the generation progress in the information window.

Result: The plant is configured and can now be started.
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3.4.3 Step 3: Assign addresses

3.4.3.1 Assigning an IP address to the IE/PB Link for the First Time

Requirements
• The IP address of the IE/PB Link must be known.

• The connection to the Ethernet LAN must be established; there must be no
subnet transition (router) between the two.

• It must be possible to access the Ethernet interface of your PG/PC from STEP
7; the PG/PC interface must be set as follows:
S7ONLINE [STEP 7] > TCP/IP > <network module>
To set the PG/PC interface, select Options > Set PG/PC interface... in
SIMATIC Manager or select Start > Simatic > SIMATIC NET > Settings > Set
PG-PC interface from the Windows taskbar

.

• The DLC protocol (Data Link Control) must be installed on the Ethernet
interface. If the DLC protocol is not installed on your PG/PC, call up the
network settings (via Control Panel > Network > Protocols) and install the
DLC protocol for your Ethernet connection.
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Procedure

 Step  Procedure
1. Open SIMATIC Manager.
2. Select Target System > Assign Ethernet Address

3. Click on the "Browse...� button to search the network for accessible modules.
All accessible stations on the network are displayed.
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 Step  Procedure
4. Select the IE/PB Link with the right MAC address from list of the suggested components.

5. Enter the IP parameters as shown in the following diagram, and assign them to the IE/PB Link.
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3.4.3.2 Assigning a PROFIBUS address to IM151/CPU for the First Time

In step 2, you assigned a PROFIBUS address to the IM151_CPU device in
SIMATIC iMap. You will have to download this PROFIBUS address from STEP 7
via MPI to the device yourself for the first time.

Requirements
• The IM151/CPU must be STOPped.

• The PG/PC must be connected to the IM151/CPU via MPI.

• The SIMATIC iMap project must have been generated. When you open the
properties of the IM151_CPU device, the generation status "Generated" must
appear on the "Instance" tab. Generate the project if this is not the case.

Procedure

 Step  Procedure
1. Set the PG/PC interface to MPI.

From the taskbar, select Start > Simatic > SIMATIC NET > Settings > PG/ PC Interface.
Configure the PG/PC interface as follows:
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 Step  Procedure
2. In the SIMATIC iMap network view, select the device IM151_CPU and then select Special >

Configuration from the context menu.

The station hardware configuration is opened in the shadow project.
3. In HW Config, select PLC > Download to Module.

In the "Select Target Module" dialog box, select the IM151/ CPU and click on "OK" to confirm.
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 Step  Procedure
4. In the "Select Station Address" dialog, enter the MPI address of the CPU or click on "OK" to

accept the displayed address, e.g:

Result: The system data, including the PROFIBUS address, are downloaded to the IM151/
CPU. The ET 200S can then communicate via the PROFIBUS.

5. Connect the ET 200S to the DP master using the PROFIBUS cable.
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3.4.4 Step 4: Check the Necessary Settings on the Engineering Station
for Plant 2

Requirements
• See chapter "System commissioning requirements"

• The PG/PC is linked to the IE/PB Link via the Ethernet.

Check the settings
Check the following settings:

• Set PG/PC interface to TCP/IP

• Assign PG/PC

Further information
Detailed information can be found in the online help for that dialog box or in the
SIMATIC iMap help topics under "Assign PG/PC".

For combination plants...
If you are using a WinLC PN, we distinguish between the two alternative set-ups:

• STEP 7 and SIMATIC iMap are on the local engineering PC, while the WinLC
PN is on a remote computer. In this case, the settings for plant 3-1 apply to the
entire plant.

• STEP 7, SIMATIC iMap and WinLC PN are all on one computer, namely the
local engineering PC. In this case, the settings for plant 3-2 apply to the entire
plant.
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3.4.4.1 Set PG/PC Interface to TCP/IP

Procedure

 Step  Procedure
1. Select Start > Simatic > SIMATIC NET > Settings >PG/ PC Interface and check the following

setting:
"TCP/IP" is set as the access point for the "S7ONLINE (STEP 7)" application.

2. Select Start > Simatic > SIMATIC NET > Settings > Set PC Station.
The configuration console opens.
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 Step  Procedure
3. Select the computer's Ethernet module from the "Structure" window.

"PG mode" must be set on the "General" tab since the PC does not have a WinLC.

4. Confirm any changes and close the configuration console.

3.4.4.2 Assign PG/PC

Note
The PG/PC assignment is automatically carried out in SIMATIC iMap when the
project is generated for the first time, and then whenever it is regenerated. In
special cases, the PG/PC assignment cannot be carried out automatically, e.g.

• there are several network cards on the PG/PC or
• the PG/PC interface S7ONLINE (STEP 7) is not set to TCP/IP.
In these cases, an error is signalled in the information window during generation,
and you will have to assign the PG/PC as described below.

The PG/PC assignment is not required if a local WinLC incorporating a network
card is used.
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Procedure

 Step  Procedure
1. Open the "Processing_A" project in SIMATIC iMap. In the network view, select any device and

then select Special > Assign PG/PC. This is necessary in order to be able to download the
program to intelligent PROFIBUS devices.

2. On the "Interfaces" tab in the "PG/PC interface" dialog box, click on the
"New" button and select "Ind. Ethernet" from the drop-down list.

Click on "OK" to confirm your choice.
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 Step  Procedure
3. In the "Properties - Ethernet Interface" dialog box, enter the IP address

and subnet mask of the local computer, then select
the Ethernet subnet.
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 Step  Procedure
4. Click on "OK" to confirm your input. Result: The interface

you have just configured appears on the "Interfaces" tab.
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 Step  Procedure
5. On the "Assignment" tab, highlight the Ethernet interface you have just configured under "Not

assigned" in the "Configured Interfaces" selection box, and in the "Interface parameter settings
on the PG/PC:" box, select
TCP/IP -> <Network card used>
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 Step  Procedure
6. Click on the "Assign" button.

Result: The assigned interface appears in the "Assigned" selection box.
Activate the "S7ONLINE access" option.

Click on "OK" to activate the assignment.
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3.4.5 Step 5: Commissioning Plant 2

Requirements
• See Chapter "System commissioning requirements"

• The PG/PC is linked to the IE/PB Link via the Ethernet.

• The IE/PB Link is linked to the DP slaves via the PROFIBUS.

• You have checked the settings in STEP 7.

• You have generated the project in SIMATIC iMap.

• All the devices are switched on.

Tip: Check the generation status
To check the generation status of a device, open the properties

• of the device in the network view

• of the technological function in the plant view.

The generation status must be "Generated". If this is not the case, generate the
project again using the Project > Generate > Changes Only menu command.
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Procedure

 Step  Procedure
1. In SIMATIC iMap:

Select the IE/PB Link from the network view.
Download the data to the device: Select Download > Selected Devices > All from the context
menu.

If the IE/PB Link is in RUN mode, you are asked whether you wish to stop the device.
Click on "Yes" to confirm the message.
Result: The device switches to STOP and the data is downloaded to the device.
You are then asked whether you want to restart the device. Click on "Yes" to confirm this
prompt.
You can then download the data to the DP slaves.

2. Select
• the devices from the network view or
• the technological functions from the plant view
the two other PROFInet components, "ET200S_Conveyor" and "ET200X_Conveyor".
Download the data to the devices: Select Download > Selected Devices > All from the
context menu.
You will receive the same prompt as in step 1 for each device. Answer "Yes" to each prompt.

Result: The devices are ready for use.
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Notes on downloading
Download the data to the DP master with proxy functionality (IE/PB Link) first, and
then to the associated DP slaves.

When changes are made to the PROFIBUS within the project by removing or
adding PROFIBUS devices, for example, then a download to both DP master and
DP slaves is required.

The program download must be carried out first, using either:

• Download > Selected Devices > All or

• Download > Selected Devices > Program Only.

Interconnections can be downloaded later.

3.4.6 Step 6: Monitor Plant 2 Online

With SIMATIC iMap, you can

• monitor online and diagnose the devices of the plant.

• display and set online values.

Requirements
• See Chapter "System commissioning requirements"

• The PG/ PC is linked to the IE/PB Link or one of the PROFInet devices via the
Ethernet.

• You have checked the settings in STEP 7.

• You have generated the project in SIMATIC iMap.

• You have downloaded the data to the devices.

• The devices are in RUN mode.
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Procedure

 Step  Procedure
1. Switch the online view on/off

In SIMATIC iMap, switch on the online view:

• click on the "Online Monitoring" icon  or
• select Online > Monitor.
You are asked whether you want to compare the devices' online and offline program data. This
comparison is optional. You can run it immediately or later.
If you answer "Yes" to this question, the data is compared and the result is displayed in the
information window.
Result: The SIMATIC iMap online view is switched on and any diagnostic information is
displayed directly at the devices and technological functions and in the diagnostic window.
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 Step  Procedure
2. Display Online Values

In the project plant view, select the "Counter_In" input of "ET200X_Conveyor" and the
"Counter_Out" output of "ET200S_Conveyor", then select the Online > Display Online
Values menu command. The online value 0 is displayed at the connectors.

3. 
Click again on the  icon or select the Online > Monitor option to switch off the online view.

Display diagnostic information
In the event of an error, diagnostic information is displayed in SIMATIC iMap in
both graphical and text format.

The diagnostic information for the technological functions can be found on the
"Functions" tab in the diagnostic window.

Example: The interconnections have to be downloaded (Online > Download
Selected Device > Interconnection Only menu command).
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The diagnostic information for the devices can be found on the "Devices" tab in the
diagnostic window.

Example: The device is not available. In this case, you will have to check the
settings and the communication links.
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3.5 Plant 3: PC-Station WinLC PN with PROFIBUS DP slaves
Plant 3 contains a PC station WinLC PN "Processing_A" with the following
PROFIBUS devices:

• ET 200S with IM151/CPU as the intelligent DP slave for controlling the
conveyor belt "ET200S_Conveyor"

• ET 200M as a DP slave, I/O module "ET200M_IO" with 2 inputs and 2 outputs

The WinLC PN is a PROFInet device and a DP master with proxy functionality for
the two DP slaves

Alternative set-up 3-1
STEP 7 and SIMATIC iMap are on the local engineering station, while the WinLC
PN is on a remote computer.
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Alternative set-up 3-2
STEP 7, SIMATIC iMap and WinLC PN are all on one computer, namely the local
engineering station.
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Basic procedure
The following tasks must be carried out:

1. Set up the plant hardware.

2. Set up the plant hardware:

- IE/PB Link

- ET 200 with IM151/CPU

- ET 200X with BM147/CPU

3. Configure the plant in SIMATIC iMap.

4. Assign addresses

- Assign an IP address to the IE/PB Link for the first time.

- Assign a PROFIBUS address to the IM151/CPU for the first time.

5. Configure the plant in SIMATIC iMap.

6. Check your settings in STEP7 in order to download the project data from
SIMATIC iMap to the plant and be able to monitor the plant online.

7. Start the plant

8. Monitor the plant online with SIMATIC iMap.

3.5.1 Step 1: Set up hardware

A PC station WinLC PN with the PROFIBUS devices ET 200S and ET 200M.

Set up the following hardware:

• WinLC PN

We distinguish between the two following situations:

- the WinLC PN is on a remote PC

- the WinLC PN is on the local engineering station that is running SIMATIC
iMap

• ET 200S with IM151/CPU

• ET 200M with BM151/CPU
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3.5.1.1 WinLC PN Hardware Set-up

Hardware required
• PC with Windows 2000 SP3 or later

• PROFIBUS connection via CP 5611, for example

Procedure

 Step  Procedure
1. Plant 3-1 only: Connect the PC to the local engineering station via the Ethernet.
2. Connect the PC to the DP slaves using the PROFIBUS cable.

3.5.1.2 ET 200M Hardware Set-up

Hardware required
You will need the following modules:

 Quantity  Designation  Order no.
1 x Interface module IM 153

(from GSD file SI801DVD.200)
6ES7 153-1AA**-0XB0

1 x Expansion module DI 4xDC24V (no power) 6ES7 321-1BH00-0AA0
1 x Expansion module DO 4xDC24V/2A 6ES7 322-1BH00-0AA0

Procedure

 Step  Procedure
1. Attach the modules to the rail
2. Set PROFIBUS address 3 on the interface module IM 153.
3. Connect the power supply.
4. Wire up the I/O modules.
5. Connect the PROFIBUS cable to the IM153-2.
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3.5.1.3 ET 200S with IM151/CPU Hardware Set-up

Hardware required
You will need the following modules:

 Quantity  Designation  Order no.
1 x Interface module IM 151 and terminating

module, 1x
6ES7 151-7AA10-0AB0 / V2.0

2 x Terminal module TM-P15S23-A1, 1x 6ES7 193-4CC30-0AA0
2 x Terminal module TM-E15S24-A1, 5x 6ES7 193-4CA20-0AA0
2 x Power module PM-E DC24 V, 1x 6ES7 138-4CA00-0AA0
1 x 2DI DC24V; high feature, 2x 6ES7 131-4BB00-0AB0
1 x 2DO DC24V; 0.5 A; high feature, 2x 6ES7 132-4BB00-0AB0
1 x Bus connector 6ES7 972-0BA10-0XA0

Procedure

 Step  Procedure
1. Attach the modules to the rail
2. Connect the power supply.
3. Wire up the I/O modules.
4. Connect the PG/PC to the IM151/CPU using the PG cable.
5. Switch on the power supply to the IM151/CPU.

Note
When you start up the ET 200S for the first time (as-delivered state), the
IM151/CPU can be accessed via MPI addresses 2, HSA 31 and 187.5 kBps. The
PROFIBUS address is assigned to the IM 151/CPU via MPI after the project is
generated in SIMATIC iMap.
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3.5.2 Step 2: Configure Plant 3 in SIMATIC iMap

This task can be carried out regardless of the plant's hardware set-up.

Requirements
You must have created the PROFInet components and they must either be present
in the file system or located in the tutorial install directory under

iMap\CBA_Tutorial\components.

Basic procedure
1. Create a new library in SIMATIC iMap, if it does not exist.

2. Import the PROFInet components from the file system to the library.

3. Paste the PROFInet components from the library into the SIMATIC iMap
project.

4. Assign addresses.

5. Interconnect technological functions and generate SIMATIC iMap project.
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Create a Library in SIMATIC iMap

 Step  Procedure
1. Start SIMATIC iMap:

• by double-clicking the  icon or
• by selecting Start > Programs > Component based Automation > SIMATIC iMap.

2. Select the Library > New... menu command.
3. Under �Search in�, select the path Programs\Siemens\iMap\Tutorial.
4. Crate a new folder named "libs"
5. In the "libs" folder, create a library with the file name "tutorial_lib�.
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 Step  Procedure
6. Click on the "Save" button to confirm your input.

Result: The library called "tutorial_lib" is created and opened in SIMATIC iMap.
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Import PROFInet Components

 Step  Procedure
1. In SIMATIC iMap, click in the "tutorial_lib" library window.

If the "tutorial_lib" library is not open, open it by selecting Library > Open
2. Import the PROFInet components from the file system to the library:

Select Import Component from the context menu in the library window.
3. Under "Search In", select the path Programs\Siemens\iMap\CBA_Tutorial\components.
4. Select the "processing_a--{...}" folder.

5. From this folder, select the "Processing_A.xml" file and click on the "Open" button to confirm
your input.
Result: The PROFInet component "Processing_A" is added to the library.
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 Step  Procedure
6. Repeat steps 3 to 5 for the following PROFInet components.

• "ET200S_Conveyor" ("et200s_conveyor--{...} folder and "ET200S_Conveyor.xml" file)
• "ET200M_IO" ("et200m_io--{...} folder and "ET200M_IO.xml" file).
Result: The two PROFInet components are added to the library.
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Paste PROFInet Components into the Project

 Step  Procedure
1. Paste the PROFInet component for the WinLC PN from the library and into the project:

Select the PROFInet component "Processing_A" from the library and
• drag it into the network view or
• select Paste Into Project from the context menu.
The PROFInet device is automatically linked to the Ethernet in the network view, and has a
PROFIBUS connector as the DP master with proxy functionality.

2. Select the PROFInet component "ET200S_Conveyor" from the library, then use Drag&Drop to
link it to the PROFIBUS with the WinLC PN.



Part 2: Commissioning the system

Component based Automation, Commissioning Systems
A5E00178020-02 3-67

 Step  Procedure
3. Repeat step 2 for the PROFInet component "ET200M_IO".

Assign Addresses

 Step  Procedure
1. Open the WinLC PN properties in the network view.

Enter the station name of the local PC station in the "Name" box on the "Instance" tab (only if
the WinLC PN is on the local engineering station, e.g. "WinLC PN")
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 Step  Procedure
2. On the "Addresses" tab, enter the IP address and subnet mask, plus the PROFIBUS address

of the device as illustrated below.

3. In the network view, open the properties of the PROFIBUS device "IM151_CPU" (ET 200S)
and enter the device's PROFIBUS address on the "Addresses" tab, e. g. 5.
Note: Exactly the same address must be assigned to the device via MPI (see Assign a
PROFIBUS address to the IM 151/CPU for the first time).
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 Step  Procedure
4. Repeat step 3 for "IM153-1" (ET 200M) and assign PROFIBUS address 3 to the device.

The network view for plant 2 then has the following appearance:

Interconnect Technological Functions and Generate Project

 Step  Procedure
1. Open the plant view. At first, the technological functions are arranged one above the other.
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 Step  Procedure
2. Arrange the technological functions and interconnect them as shown below:

3. Make sure that the �tutorial_lib� library is open.
Generate the project:
• using the Project > Generate > Changes Only menu command or

• by clicking on the "Generate" icon .
If you have not yet saved the project, you will be prompted to enter a name for the project. In
the "Save Simatic iMap Project As" dialog box, select a path and enter a name, e.g. "Plant_3".
Result: The project is saved and generated.
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 Step  Procedure
4. You can follow the generation progress in the information window.

Result: The plant is configured and can now be started.

3.5.3 Step 3: Assigning a PROFIBUS address to the IM151/CPU for the
First Time

In step 2, you assigned a PROFIBUS address to the IM151_CPU device in
SIMATIC iMap. You will have to download this PROFIBUS address from STEP 7
via MPI to the device yourself for the first time.

Requirements
• The IM151/CPU must be STOPped.

• The PG/PC must be connected to the IM151/CPU via MPI.

• The SIMATIC iMap project must have been generated. When you open the
properties of the IM151_CPU device, the generation status "Generated" must
appear on the "Instance" tab. Generate the project if this is not the case.
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Procedure

 Step  Procedure
1. Set the PG/PC interface to MPI.

From the taskbar, select Start > Simatic > SIMATIC NET > Settings > PG/ PC Interface.
Configure the PG/PC interface as follows:

2. In the SIMATIC iMap network view, select the device IM151_CPU and then select Special >
Configuration from the context menu.

The station hardware configuration is opened in the shadow project.
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 Step  Procedure
3. In HW Config, select PLC > Download to Module.

In the "Select Target Module" dialog box, select the IM151/ CPU and click on "OK" to confirm.
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 Step  Procedure
4. In the "Select Station Address" dialog, enter the MPI address of the CPU or click on "OK" to

accept the displayed address, e.g:

Result: The system data, including the PROFIBUS address, are downloaded to the IM151/
CPU. The ET 200S can then communicate via the PROFIBUS.

5. Connect the ET 200S to the DP master using the PROFIBUS cable.
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3.5.4 Step 4: Check Settings Required for Download and Online
Functions

There are two different cases:

• Settings for plant 3-1: STEP 7 und SIMATIC iMap befinden sich auf dem
lokalen Engineering-PC und die WinLC PN auf einem entfernten Rechner.

• Settings for plant 3-2: STEP 7, SIMATIC iMap and WinLC PN are all on the
same computer - the local engineering station.

3.5.4.1 Check Settings for Plant 3-1

Requirements
• See Chapter "System commissioning requirements"

• The WinLC PN V1.1 software package must be installed on the remote PC.

Check the settings
Check the following settings:

• On the local engineering PG/PC,
Set the PG/PC interface to TCP/IP

• On the local engineering PG/PC, Assign PG/PC

• On the remote PC station with WinLC PN,
Set PG/PC interface to "PC internal". These settings are identical for Plant 3-1
and 3-2.
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3.5.4.2 Set PG/PC Interface to TCP/IP

Procedure

 Step  Procedure
1. Select Start > Simatic > SIMATIC NET > Settings >PG/ PC Interface and check the following

setting:
"TCP/IP" is set as the access point for the "S7ONLINE (STEP 7)" application.

2. Select Start > Simatic > SIMATIC NET > Settings > Set PC Station.
The configuration console opens.



Part 2: Commissioning the system

Component based Automation, Commissioning Systems
A5E00178020-02 3-77

 Step  Procedure
3. Select the computer's Ethernet module from the "Structure" window.

"PG mode" must be set on the "General" tab since the PC does not have a WinLC.

4. Confirm any changes and close the configuration console.

3.5.4.3 Assign PG/PC

Note
The PG/PC assignment is automatically carried out in SIMATIC iMap when the
project is generated for the first time, and then whenever it is regenerated. In
special cases, the PG/PC assignment cannot be carried out automatically, e.g.

• there are several network cards on the PG/PC or
• the PG/PC interface S7ONLINE (STEP 7) is not set to TCP/IP.
In these cases, an error is signalled in the information window during generation,
and you will have to assign the PG/PC as described below.

The PG/PC assignment is not required if a local WinLC incorporating a network
card is used.
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Procedure

 Step  Procedure
1. Open the "Processing_A" project in SIMATIC iMap. In the network view, select any device and

then select Special > Assign PG/PC. This is necessary in order to be able to download the
program to intelligent PROFIBUS devices.

2. On the "Interfaces" tab in the "PG/PC interface" dialog box, click on the
"New" button and select "Ind. Ethernet" from the drop-down list.

Click on "OK" to confirm your choice.
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 Step  Procedure
3. In the "Properties - Ethernet Interface" dialog box, enter the IP address

and subnet mask of the local computer, then select
the Ethernet subnet.
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 Step  Procedure
4. Click on "OK" to confirm your input. Result: The interface

you have just configured appears on the "Interfaces" tab.
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 Step  Procedure
5. On the "Assignment" tab, highlight the Ethernet interface you have just configured under "Not

assigned" in the "Configured Interfaces" selection box, and in the "Interface parameter settings
on the PG/PC:" box, select
TCP/IP -> <Network card used>
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 Step  Procedure
6. Click on the "Assign" button.

Result: The assigned interface appears in the "Assigned" selection box.
Activate the "S7ONLINE access" option.

Click on "OK" to activate the assignment.

3.5.4.4 Set PG/PC Interface on the WinLC PN PC Station

These settings are necessary on the WinLC PC Station of both plant 3-1 and 3-2.

Requirements
• See Chapter "System commissioning requirements"

• The WinLC PN V1.1 software package must be installed on the local
engineering PC.

Note
If there is a WinLC PN on the local engineering station, the online connection
between SIMATIC iMap and the devices of the plant is controlled via the station
manager for the WinLC PN, so the local PC station must be configured
accordingly.
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Procedure

 Step  Procedure
1. Open the Station Configuration Editor by

• clicking on the  icon on the taskbar or
• by selecting Start > Programs > Startup > Station Configuration Editor.

2. Check
• that the station name of the local engineering station with the WinLC PN is the same as

the device name of the "Processing_A" component in the SIMATIC iMap network view and
• that the index of the IE_CP is the same as the CP "IE General" slot in the component

project in STEP 7/HW Config.
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 Step  Procedure
3. Select Start > Simatic > SIMATIC NET > Settings > Set PC Station.

The configuration console opens.

4. Under "Modules" in the "Structure" window, select the Ethernet module of the computer.
"Configured mode" is set as the operating mode under "General".
The index must be the same as the CP "IE General" slot in the component project in STEP
7/HW Config.
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 Step  Procedure
5. Select the PROFIBUS module of the computer.

"PG mode" must be set as the operating mode under "General".

6. Select "Access Points" and check the following settings:
• The local PROFIBUS module is set as the access point for the "CP_L2_1" application.
• "PC internal (local)� is set as the access point for the "S7ONLINE (STEP 7)" application.

7. Confirm any changes and close the configuration console.
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Tip
You can also set or check the access points using Start > Settings > Control
Panel > Set PG/PC Interface.

3.5.5 Step 5: Commissioning Plant 3

Requirements
• See Chapter �System commissioning requirements"

• You have checked the settings in STEP 7.

• You have generated the project in SIMATIC iMap.

• Plant 3-1 only:
The local engineering station is linked to the remote PC (PC station with
WinLC PN) via the Ethernet.

• The PC station with WinLC PN is linked to the DP slaves via the PROFIBUS.

• WinLC PN has been started.

Tip: Check the generation status
To check the generation status of a device, open the properties

• of the device in the network view

• of the technological function in the plant view.

The generation status must be "Generated". If this is not the case, generate the
project again using the Project > Generate > Changes Only menu command.
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Procedure

 Step  Procedure
1. In SIMATIC iMap:

Select the WinLC PN from the network view.
Download the data to the device: Select Download > Selected Devices > All from the context
menu.

If the WinLC PN is in RUN mode, you are asked whether you wish to stop the device.
Click on "Yes" to confirm the message.
Result: The WinLC PN switches to STOP and the data is downloaded to the device.
You are then asked whether you want to restart the device. Click on "Yes" to confirm this
prompt.
You can then download the data to the DP slaves.

2. Select
• the devices from the network view or
• the technological functions from the plant view
the two other PROFInet components, "ET200S_Conveyor" and "ET200M_IO".
Download the data to the devices: Select Download > Selected Devices > All from the
context menu.
You will receive the same prompt as in step 2 for the IM151/CPU. Answer "Yes" to each
prompt.

Result: The devices are ready for use.
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Notes on downloading
Download the data to the DP master with proxy functionality (WinLC PN) first, and
then to the associated DP slaves.

When changes are made to the PROFIBUS within the project by removing or
adding PROFIBUS devices, for example, then a download to both DP master and
DP slaves is required.

The program download must be carried out first, using either:

• Download > Selected Devices > All or

• Download > Selected Devices > Program Only.

Interconnections can be downloaded later.

3.5.6 Step 6: Monitor Plant 3 Online

Requirements
• See Chapter "System commissioning requirements"

• The PG/ PC is linked to the PC station or one of the PROFInet devices via the
Ethernet.

• You have checked the settings in STEP 7.

• You have generated the project in SIMATIC iMap.

• You have downloaded the data to the devices.

• The WinLC PN is in RUN or RUN-P mode, and the IM151/CPU is in RUN
mode.
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Procedure

 Step  Procedure
1. Switch the online view on/off

In SIMATIC iMap, switch on the online view:

• click on the "Online Monitoring" icon  or
• select Online > Monitor.
You are asked whether you want to compare the devices' online and offline program data. This
comparison is optional. You can run it immediately or later.
If you answer "Yes" to this question, the data is compared and the result is displayed in the
information window.
Result: The SIMATIC iMap online view is switched on and any diagnostic information is
displayed directly at the devices and technological functions and in the diagnostic window.



Part 2: Commissioning the system

Component based Automation, Commissioning Systems
3-90 A5E00178020-02

 Step  Procedure
2. Display Online Values

In the project plant view, select the "Counter_In" input of "ET200S_Conveyor" and the
"Counter_Out" output of "Processing_A", then select the Online > Display Online Values
menu command. The online value 1 is displayed at the connectors.

3. 
Click again on the  icon or select the Online > Monitor option to switch off the online view.
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Display diagnostic information
In the event of an error, diagnostic information is displayed in SIMATIC iMap in
both graphical and text format.

The diagnostic information for the technological functions can be found on the
"Functions" tab in the diagnostic window.

Example: The interconnections have to be downloaded for the ET200M (Online >
Download Selected Device > Interconnection Only menu command).

The diagnostic information for the devices can be found on the "Devices" tab in the
diagnostic window.
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Example: The device is not available. In this case, you will have to check the
settings and the communication links.
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3.6 Overall plant

3.6.1 Overall plant: Set up Hardware

You can combine plants 1 to 3 to form an overall plant. The procedure is as
follows:

 Step  Procedure
1. Set up all the devices as described for plants 1 to 3.
2. Connect the CP 343-1 PN, the IE/PB Link and the PC station with the WinLC PN

via the Ethernet.
3. Connect the engineering PC (running SIMATIC iMap) with the above devices via

the Ethernet.

3.6.2 Configure the Overall Plant

Configure the overall plant in SIMATIC iMap

 Step  Procedure
1. Start SIMATIC iMap and make sure that the library "tutorial_lib.cbl" is open and contains all

the PROFInet components for the 3 plants.

If necessary, import the missing PROFInet components using Library > Import Component.
2. In SIMATIC iMap, select Project > New to open a new project.
3. Select Project > Save to save the project with the name "Tutorial_Plant".
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 Step  Procedure
4. Drag the PROFInet components from the library and drop them into the project network view in

the following order:
• Processing_B
• IE-PB-Link 1_5MB
• ET200S_Conveyor to the PROFIBUS with the IE/PB Link
• ET200X_Conveyor to the PROFIBUS with the IE/PB Link
• Processing_A
• ET200S_Conveyor to the PROFIBUS with the WinLC PN
• ET200M_IO to the PROFIBUS with the WinLC PN

5. Assign the IP or PROFIBUS addresses to the devices as described for plants 1 to 3.
The project in the network view then has the following appearance:
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 Step  Procedure
6. Switch to the plant view and interconnect the technological functions as shown below:

The interconnection lines on the plant are converted into communication links so that the data
can be transferred via industrial Ethernet and PROFIBUS. The value of the Counter_Out
output is sent to the Counter_In input, etc.

7. Select Project > Generate to generate the project.

Result: The overall plant is now configured in SIMATIC iMap.
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3.6.3 Check the Settings

Requirement
For the overall plant, STEP 7 and SIMATIC iMap are on the local engineering
station, while the WinLC PN is on a remote computer.

Check the settings
Check the following settings:

• On the local engineering PG/PC,
Set the PG/PC interface to TCP/IP

• On the local engineering PG/PC,
Assign PG/PC

• On the remote PC station with WinLC PN,
Set PG/PC interface to "PC internal".
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3.6.4 Start the Overall Plant

Start the overall plant

 Step  Procedure
1. In SIMATIC iMap:

Select the WinLC PN from the network view.
Download the data to the device: Select Download > Selected Devices > All from the context
menu.

If the WinLC PN is in RUN mode, you are asked whether you wish to stop the device.
Click on "Yes" to confirm the message.
Result: The WinLC PN switches to STOP and the data is downloaded to the device.
You are then asked whether you want to restart the device. Click on "Yes" to confirm this
prompt.
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 Step  Procedure
2. Select the IE/PB Link from the network view.

Download the data to the device: Select Download > Selected Devices > All from the context
menu.

If the IE/PB Link is in RUN mode, you are asked whether you wish to stop the device.
Click on "Yes" to confirm the message.
Result: The device switches to STOP and the data is downloaded to the device.
You are then asked whether you want to restart the device. Click on "Yes" to confirm this
prompt.
You can then download the data to the other devices of the plant

3. Select
• the devices from the network view or
• the technological functions from the plant view
the other PROFInet components:
• Processing_B/CPU 315-2 DP
• ET200S_Conveyor/IM151_CPU (twice)
• ET200X_Conveyor/BM147_CPU
• ET200_IO/IM 153-1
Download the data to the devices: Select Download > Selected Devices > All from the
context menu.
For the IM151/CPU, BM147/CPU and CP343-1PN you will see the same prompts as for steps
1 and 2. Click on "Yes" to confirm all these prompts.

Result: The devices are ready for use.
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Notes on downloading
Download the data to the DP master(s) with proxy functionality (WinLC PN, IE/PB
Link) first, and then to the associated DP slaves.

When changes are made to the PROFIBUS within the project by removing or
adding PROFIBUS devices, for example, then a download to both DP master and
DP slaves is required.

The program download must be carried out first, using either:

• Download > Selected Devices > All or

• Download > Selected Devices > Program Only.

Interconnections can be downloaded later.
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3.6.5 Monitor the Overall Plant Online

Monitor the overall plant online

 Step  Procedure
1. Switch the online view on/off

In SIMATIC iMap, switch on the online view:

• click on the "Online Monitoring" icon  or
• select Online > Monitor.
You are asked whether you want to compare the devices' online and offline program data. This
comparison is optional. You can run it immediately or later.
If you answer "Yes" to this question, the data is compared and the result is displayed in the
information window.
Result: The SIMATIC iMap online view is switched on and any diagnostic information is
displayed directly at the devices and technological functions and in the diagnostic window.
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4 Literature and Links

Requirement
• the SIMATIC Manual Collection, which contains all the current manuals, or

• an Internet connection. Here you will find constantly updated information in the
form of FAQs and manuals and software for downloading.

Literature and links
Links to manuals containing further information about the devices and on working
with SIMATIC iMap are given below.

 Title  Link or download address

SIMATIC iMap manuals SIMATIC iMap Manuals
S7-CPs Manual / Part B2 Description of the
CP 343-1 PN
Edition 04

Description of CP 343-1 PN

SIMATIC NET IE/PB Link Gateway
Edition 11/2002

Description of  IE/PB Link

SIMATIC Component based Automation -
WinLC PN Addendum to WinAC Basis V3.0
Edition: 07/2001

Description of  WinLC PN

SIMATIC Distributed I/O System ET  200S
Edition 12/2001

Distributed I/O System ET  200S

SIMATIC ET 200S
Interface Module IM 151-7 CPU
Edition 09/2002

SIMATIC ET 200S Interface Module
IM151/CPU

SIMATIC Distributed I/O System ET  200X
Edition 05/2001

Distributed I/O System ET  200X

SIMATIC ET  200X
Basic module BM147/CPU
Edition 07/1999

SIMATIC ET 200X Basic Module BM147/CPU

SIMATIC Distributed I/O System  ET 200M
Edition 07/00

Distributed I/O System ET 200M

SIMATIC Manual Collection
Edition 11/2002

SIMATIC Manual Collection

Information on
Component based Automation

Component based Automation

http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objid=8131230&objAction=csopen&siteid=cs&lang=de
http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objid=8776538&objAction=csopen&siteid=cs&lang=de
http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objid=7851748&objAction=csopen&siteid=cs&lang=de
http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objid=9857682&objAction=csopen&siteid=cs&lang=de
http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objid=9857682&objAction=csopen&siteid=cs&lang=de
http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objid=12714722&objAction=csopen&siteid=cs&lang=de
http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objid=1142469&objAction=csopen&siteid=cs&lang=de
http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objid=1142364&objAction=csopen&siteid=cs&lang=de
http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objid=1142798&objAction=csopen&siteid=cs&lang=de
http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objid=12684133&objAction=csopen&siteid=cs&lang=de
http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objid=12684133&objAction=csopen&siteid=cs&lang=de
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